$re = '/R\d+:/m';
$str = 'R1:C1[6]|R1:C1[12]-[P1_G]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);