re = /[-+]?([1-8]?\d(\.\d+)?|90(\.0+)?),\s*[-+]?(180(\.0+)?|((1[0-7]\d)|([1-9]?\d))(\.\d+)?)/
str = 'dfdf 47.1231231,179.99999999 dsgdfg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end