$re = '/AB-?\d+(?:\(-?\d+\))?\s*[A-Za-z]*\K\d+(?:\.\d+)?/m';
$str = 'Word AB70 60.1 Another
Word AB70 60 Another
Word AB70 D65.1 Another
Word AB70(-20) D65.1 Another
Word AB-70 D65.1 Another';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);