import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\/==start==\\n(.+\\n)*\\/\\/==end==";
final String string = "var originalString = `// @Author: someone\n"
+ "// @Date: 2018-01-23T16:46:09-04:00\n"
+ "// @Email: dddddddd@gmail.com\n"
+ "// @Filename: _material.themes.scss\n"
+ "// @Last modified by: Someone\n"
+ "// @Last modified time: 2018-01-23T18:40:39-04:00\n\n"
+ "@include angular-material-theme($theme);\n\n"
+ ".app-dark {\n"
+ " @include angular-material-theme($dark-theme);\n"
+ "}\n\n"
+ ".app-pink {\n"
+ " @include angular-material-theme($pink-theme);\n"
+ "}\n\n"
+ "//==start==\n"
+ "//==end==`";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}