# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^a-z:]+?)\s*:\s*(.*?)\s*(?=^[^a-z:]+?:|\Z)"
test_str = ("JOHN SMITH, GLOBAL HEAD OF YOUTUBE : Good morning, good \n"
"afternoon, everyone . Before I hand over to facebook, I want to give a quick reminder of the reporting \n"
"changes that have taken effect this filming of a tv show. \n"
" \n\n"
" \n"
"BOBBY DUDE, GROUP FROM FACEBOOK: Thanks, john smith lets talk about movies and films we watch when we are bored parents. \n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.