$re = '/([\dA-Z]\.)+[\dA-Z]?/m';
$str = '1.1.1.1 Abc
B.1.1.1 Abc
B. Abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);