import re
regex = re.compile(r",(?=\S)")
test_str = "1234567,01/15/23,01/15/23,Debit Card,-135.0,,SUPER BLAND, DDS,Health & Fitness,DR,1234.56"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")