#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*\d{2}/\d{2}/\d{4}.+\(PID-\d{6}\):"
Local $sString = "12/27/2016 08:05 AM (GMT+01:00) added by Operator A (PID-000301):" & @CRLF & _
"Others/Malfunction;Device failure not specified;It Crasched during upgrade" & @CRLF & _
"" & @CRLF & _
"*************************************************************************************************" & @CRLF & _
"12/26/2016 08:06 AM (GMT+01:00) added by Operator B (PID-000301):" & @CRLF & _
"Others/Malfunction;Device failure not specified;It Crasched during upgrade" & @CRLF & _
"" & @CRLF & _
"*************************************************************************************************" & @CRLF & _
"12/23/2016 08:06 AM (GMT+01:00) added by Operator C (PID-000301):" & @CRLF & _
"Others/Malfunction;Device failure not specified;It Crasched during upgrade" & @CRLF & _
"" & @CRLF & _
"*************************************************************************************************" & @CRLF & _
"12/22/2016 08:05 AM (GMT+01:00) added by Operator A (PID-000301):" & @CRLF & _
"Others/Malfunction;Device failure not specified;It Crasched during upgrade" & @CRLF & _
"" & @CRLF & _
"*************************************************************************************************" & @CRLF & _
"12/22/2016 12:57 AM (GMT+01:00) added by Operator B (PID-000301):" & @CRLF & _
"Others/Malfunction;Device failure not specified;It Crasched during upgrade" & @CRLF & _
"" & @CRLF & _
"*************************************************************************************************" & @CRLF & _
"12/21/2016 02:03 AM (GMT+01:00) added by Operator C (PID-000301):" & @CRLF & _
"Others/Malfunction;Device failure not specified;It Crasched during upgrade" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")