// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bhttps?:\S+ *").unwrap();
let string = "眼影盤長這樣 http://i.imgur.com/uxvRo3h.jpg 說真的 很不好拍";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}