re = /^(\d{1,2})\/(\d{1,2})\/(\d{4}) (\d{1,2}):(\d{1,2}) ([AP]M)$/m
str = '07/19/2020 08:40 PM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end