const regex = /\]\s+(?<Transaction_ID>.*)\s+STATUS:\s(?<STATUS>.*)\s+JOB:\s+(?<JOB>.*)\s+MACHINE:\s+(?<MACHINE>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\]\\s+(?<Transaction_ID>.*)\\s+STATUS:\\s(?<STATUS>.*)\\s+JOB:\\s+(?<JOB>.*)\\s+MACHINE:\\s+(?<MACHINE>.*)', 'gm')
const str = `[02/18/2020 10:47:15.1318] CAUAJM_I_40245 EVENT: CHANGE_STATUS STATUS: STARTING JOB: CFDW_ADHOC_C_AIMSAS_D_INV_LNITEM_BILLING_CHGS_M MACHINE: XXXX
[02/18/2020 10:48:15.1318] CAUAJM_I_40245 EVENT: CHANGE_STATUS STATUS: RUNNING JOB: CFDW_ADHOC_C_AIMSAS_D_INV_LNITEM_BILLING_CHGS_M MACHINE: XXXX
[02/18/2020 18:25:15.1318] CAUAJM_I_40245 EVENT: CHANGE_STATUS STATUS: SUCCESS JOB: CFDW_ADHOC_C_AIMSAS_D_INV_LNITEM_BILLING_CHGS_M MACHINE: XXXX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}