$re = '/(;?)(\d+)$/m';
$str = 'Pepsi 90s Drink001';
$subst = "/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;