import Foundation
let pattern = #"\bST(?!REET\b)(?:REET)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
703 6TH STREET SOUTHTEXAS CITY TX 77590
1201 WEST FRONT STREETCHESTER PA 19013-3496
1201 WEST FRONT STCHESTER PA 19013-3496
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<0> "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)