#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([a-zA-Z0-9_[\]]+)\s?((=|<|>|<=|>=)=?)\s?([-+]?([0-9]*\.[0-9]+|[0-9]+))\s?\(?(\w*)\)?\s?([-+±\s]*?([0-9]*\.[0-9]+|[0-9]+)\s?[a-zA-Z]*)?\s?(in|for)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?(\sfor|\sin)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?"
Local $sString = "Em01_Trq = 500 Nm +-50" & @CRLF & _
"Em01_Trq=-500Nm" & @CRLF & _
"Em01_Trq<+500rpm in 100ms for 10s" & @CRLF & _
"Em01_Trq<=-500rpm for 10s" & @CRLF & _
"Em01_Trq>=-500rpm in 10.5s" & @CRLF & _
"Em01_xxx>-500.505rpm" & @CRLF & _
"Em_md = 1(Torque)" & @CRLF & _
"Em_md = 1(Torque) in 50ms" & @CRLF & _
"Em_md = 1(Torque) " & @CRLF & _
"[Em_md] = 1(Torque) for 50.1min" & @CRLF & _
"Em01_Trq = 500 rpm +-50.6" & @CRLF & _
"EM01_PhaseCurr = 0 A ± 1 in 225ms"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)