re = /^[^.]*\.\s*(?=.*\bcosts\b)(.*\bapple\b.*\.)$/m
str = 'Monday evening. Supermarket. This apple costs 0.99. Too expensive.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end