using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\w\.]\.net\b";
string input = @"Full-Stack Developer (Angular, .net Core, SQL) .network
Full-Stack Developer (Angular, ..net Core, SQL) .network ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}