re = /((?:\s)*(.+?)(?:\s)*=(?:\s)*(.+?)(?:\s)*(?:;|$))/m
str = ' Driver={SQL Server}; Server = testsvr ;Database= testdb;UID=sa;PWD=pwd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end