re = /.*BOURKE[^\r\n]*/i
str = 'initial text
preliminary text
unfinished line bfore the line I want
001 BOURKE, Bridget Mary ....... ........... 13 Mahina Road, Mahina Bay.Producrs/As 002 BOURKE. David Gerard ...
line after the line I want
extra text
extra extra text'
# Print the match result
str.match(re) do |match|
puts match.to_s
end