package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(0*)(\d*)`)
var str = `dfdfsddsfsdf234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}