$re = '/myuser=@([^\s]+) /m';
$str = 'So for example my string is like this myuser=alex@alex.com but further in the string I have nouser=ted@ted.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);