#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Alarm:\s+0:\s+T AL:\s+(?P<Temp_AL_0>[+-]\d+\.\d+)\,\s+t AL:\s+(?P<time_AL_0>\d+)\s+1:\s+T AL:\s+(?P<Temp_AL_1>[+-]\d+\.\d+)\,\s+t AL:\s+(?P<time_AL_1>\d+)"
Local $sString = "Device: Q-tag Fridge-tag 2" & @CRLF & _
"Vers: 0.5" & @CRLF & _
"Fw Vers: 3.4p0o" & @CRLF & _
"Sensor: 4" & @CRLF & _
"Conf:" & @CRLF & _
" Serial: 130400141244" & @CRLF & _
" PCB: BG0211306532" & @CRLF & _
" CID: 1000" & @CRLF & _
" Lot: 1792_20_08" & @CRLF & _
" Zone: 0.00" & @CRLF & _
" Measurement delay: 10" & @CRLF & _
" Moving Avrg: 1" & @CRLF & _
" User Alarm Config: 0" & @CRLF & _
" User Clock Config: 1" & @CRLF & _
" Alarm Indication: 0" & @CRLF & _
" Temp unit: C" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" T AL: -0.5, t AL: 60" & @CRLF & _
" 1:" & @CRLF & _
" T AL: +8.3, t AL: 600" & @CRLF & _
" Int Sensor:" & @CRLF & _
" Timeout: 1, Offset: +0.0" & @CRLF & _
" Report history length: 60" & @CRLF & _
" Det Report: 3" & @CRLF & _
" Use ext devices: 0" & @CRLF & _
" Test Res: 1, Test TS: 2021-05-20 12:51" & @CRLF & _
"Hist:" & @CRLF & _
" TS Actv: 2022-03-05 11:09" & @CRLF & _
" TS Report Creation: 2022-03-28 07:26" & @CRLF & _
" 1:" & @CRLF & _
" Date: 2022-03-28" & @CRLF & _
" Min T: +3.2, TS Min T: 05:24" & @CRLF & _
" Max T: +3.5, TS Max T: 00:00" & @CRLF & _
" Avrg T: +3.3" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 8" & @CRLF & _
" Checked:" & @CRLF & _
" TS AM: 07:20" & @CRLF & _
" 2:" & @CRLF & _
" Date: 2022-03-27" & @CRLF & _
" Min T: +2.9, TS Min T: 06:02" & @CRLF & _
" Max T: +3.8, TS Max T: 17:13" & @CRLF & _
" Avrg T: +3.2" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 3:" & @CRLF & _
" Date: 2022-03-26" & @CRLF & _
" Min T: +2.3, TS Min T: 01:57" & @CRLF & _
" Max T: +3.3, TS Max T: 16:49" & @CRLF & _
" Avrg T: +2.8" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 4:" & @CRLF & _
" Date: 2022-03-25" & @CRLF & _
" Min T: +2.1, TS Min T: 01:07" & @CRLF & _
" Max T: +2.8, TS Max T: 16:04" & @CRLF & _
" Avrg T: +2.4" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 5:" & @CRLF & _
" Date: 2022-03-24" & @CRLF & _
" Min T: +1.8, TS Min T: 01:35" & @CRLF & _
" Max T: +2.5, TS Max T: 18:48" & @CRLF & _
" Avrg T: +2.1" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 6:" & @CRLF & _
" Date: 2022-03-23" & @CRLF & _
" Min T: +1.7, TS Min T: 09:23" & @CRLF & _
" Max T: +2.2, TS Max T: 16:23" & @CRLF & _
" Avrg T: +1.9" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 7:" & @CRLF & _
" Date: 2022-03-22" & @CRLF & _
" Min T: +2.0, TS Min T: 06:18" & @CRLF & _
" Max T: +2.3, TS Max T: 00:09" & @CRLF & _
" Avrg T: +2.0" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 8:" & @CRLF & _
" Date: 2022-03-21" & @CRLF & _
" Min T: +2.2, TS Min T: 21:03" & @CRLF & _
" Max T: +2.8, TS Max T: 00:00" & @CRLF & _
" Avrg T: +2.4" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 9:" & @CRLF & _
" Date: 2022-03-20" & @CRLF & _
" Min T: +2.7, TS Min T: 23:40" & @CRLF & _
" Max T: +3.1, TS Max T: 12:47" & @CRLF & _
" Avrg T: +2.9" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 10:" & @CRLF & _
" Date: 2022-03-19" & @CRLF & _
" Min T: +3.0, TS Min T: 06:10" & @CRLF & _
" Max T: +4.1, TS Max T: 10:59" & @CRLF & _
" Avrg T: +3.2" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 11:" & @CRLF & _
" Date: 2022-03-18" & @CRLF & _
" Min T: +2.8, TS Min T: 05:37" & @CRLF & _
" Max T: +3.6, TS Max T: 16:54" & @CRLF & _
" Avrg T: +3.2" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 12:" & @CRLF & _
" Date: 2022-03-17" & @CRLF & _
" Min T: +3.1, TS Min T: 21:34" & @CRLF & _
" Max T: +4.6, TS Max T: 10:35" & @CRLF & _
" Avrg T: +3.4" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 13:" & @CRLF & _
" Date: 2022-03-16" & @CRLF & _
" Min T: +3.5, TS Min T: 21:44" & @CRLF & _
" Max T: +4.2, TS Max T: 12:21" & @CRLF & _
" Avrg T: +3.7" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 14:" & @CRLF & _
" Date: 2022-03-15" & @CRLF & _
" Min T: +3.7, TS Min T: 07:28" & @CRLF & _
" Max T: +5.2, TS Max T: 08:21" & @CRLF & _
" Avrg T: +3.9" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 8" & @CRLF & _
" Checked:" & @CRLF & _
" TS AM: 08:08" & @CRLF & _
" 15:" & @CRLF & _
" Date: 2022-03-14" & @CRLF & _
" Min T: +4.0, TS Min T: 20:45" & @CRLF & _
" Max T: +5.3, TS Max T: 09:01" & @CRLF & _
" Avrg T: +4.2" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 16:" & @CRLF & _
" Date: 2022-03-13" & @CRLF & _
" Min T: +4.1, TS Min T: 11:42" & @CRLF & _
" Max T: +4.8, TS Max T: 01:32" & @CRLF & _
" Avrg T: +4.4" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 17:" & @CRLF & _
" Date: 2022-03-12" & @CRLF & _
" Min T: +4.1, TS Min T: 14:05" & @CRLF & _
" Max T: +4.9, TS Max T: 21:34" & @CRLF & _
" Avrg T: +4.6" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 18:" & @CRLF & _
" Date: 2022-03-11" & @CRLF & _
" Min T: +4.2, TS Min T: 06:22" & @CRLF & _
" Max T: +4.9, TS Max T: 15:38" & @CRLF & _
" Avrg T: +4.5" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 19:" & @CRLF & _
" Date: 2022-03-10" & @CRLF & _
" Min T: +3.8, TS Min T: 00:05" & @CRLF & _
" Max T: +5.1, TS Max T: 10:27" & @CRLF & _
" Avrg T: +4.1" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 20:" & @CRLF & _
" Date: 2022-03-09" & @CRLF & _
" Min T: +3.3, TS Min T: 06:05" & @CRLF & _
" Max T: +4.0, TS Max T: 12:03" & @CRLF & _
" Avrg T: +3.6" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 21:" & @CRLF & _
" Date: 2022-03-08" & @CRLF & _
" Min T: +3.3, TS Min T: 05:16" & @CRLF & _
" Max T: +4.1, TS Max T: 08:48" & @CRLF & _
" Avrg T: +3.7" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 8" & @CRLF & _
" Checked:" & @CRLF & _
" TS AM: 08:36" & @CRLF & _
" 22:" & @CRLF & _
" Date: 2022-03-07" & @CRLF & _
" Min T: +3.7, TS Min T: 23:41" & @CRLF & _
" Max T: +4.5, TS Max T: 00:00" & @CRLF & _
" Avrg T: +4.1" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 0" & @CRLF & _
" 23:" & @CRLF & _
" Date: 2022-03-06" & @CRLF & _
" Min T: +4.0, TS Min T: 04:03" & @CRLF & _
" Max T: +7.1, TS Max T: 08:54" & @CRLF & _
" Avrg T: +4.5" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 8" & @CRLF & _
" Checked:" & @CRLF & _
" TS AM: 08:43" & @CRLF & _
" 24:" & @CRLF & _
" Date: 2022-03-05" & @CRLF & _
" Min T: +4.3, TS Min T: 23:23" & @CRLF & _
" Max T: +14.9, TS Max T: 11:23" & @CRLF & _
" Avrg T: +5.0" & @CRLF & _
" Alarm:" & @CRLF & _
" 0:" & @CRLF & _
" t Acc: 0" & @CRLF & _
" 1:" & @CRLF & _
" t Acc: 31" & @CRLF & _
" Int Sensor timeout:" & @CRLF & _
" t AccST: 0" & @CRLF & _
" Events: 24" & @CRLF & _
" Checked:" & @CRLF & _
" TS AM: 11:09" & @CRLF & _
" TS PM: 12:45" & @CRLF & _
"Cert:" & @CRLF & _
" Vers: 1.0" & @CRLF & _
" Lot: 1792_20_08" & @CRLF & _
" Issuer: Berlinger & Co. AG" & @CRLF & _
" Valid from: 2020-08-21 07:39" & @CRLF & _
" Owner: Berlinger & Co. AG" & @CRLF & _
" Public Key: d73cd26b379bd0a250d98498e15c739ab53594e9768b247a0713637cba30e474b4fcc1aae45f30ec7cc878c102cf9648d775670d2f93b48726a0f21d3ca71074" & @CRLF & _
"Sig Cert: 6eef7b154b51a1f4a4186e76b495d43dc25cedbaab8b18486895df5d773530795679b8aa3678e511e45e28cb894bcc051dd90d13f19f699c4f42b46c4ed5d621" & @CRLF & _
"Sig: ec3ca65a802abce36aacf3e12679075acf05c8f55586e79c16a489c59ac4f3b975f34b4d1596a2083a31b1f6172bcca388463a95e4f2ed63bdc5808433fb6820" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")