$re = '/(?:\.0)+$/m';
$str = 'Android 7.0.0';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;