import Foundation
let pattern = #"(?<=^\$translateProvider\.translations\('de', {)[\s\S]*(?=}\)$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$translateProvider.translations('de', {
        WASTE_MANAGEMENT: 'Abfallmanagement',
        WASTE_TYPE_LIST: 'Abfallarten',
        WASTE_ENTRY_LIST: 'Abfalleinträge',
        WASTE_TYPE: 'Abfallart',
        TREATMENT_TYPE: 'Behandlungsart',
        TREATMENT_TYPE_STATUS: 'Status Behandlungsart',
        DUPLICATED_TREATMENT_TYPE: 'Doppelte Behandlungsart',
        TREATMENT_TYPE_LIST: 'Behandlungsarten',
        TREATMENT_TARGET_LIST: 'Ziele Behandlungsarten',
        TREATMENT_TARGET_ADD: 'Ziel Behandlungsart hinzufügen',
        SITE_TARGET: 'Gebäudeziel',
        WASTE_TREATMENT_TYPES: 'Abfallbehandlungsarten',
        WASTE_TREATMENT_TARGETS: '{{Abfallbehandlungsziele}}',
        WASTE_TREATMENT_TYPES_LIST: '{{Abfallbehandlungsarten}}',
        WASTE_TYPE_ADD: 'Abfallart hinzufügen',
        UNIT_ADD: 'Einheit hinzufügen'
})
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
    let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
    print(result)
} else {
    print("No matches were found.")
}