$re = '/\$([a-zA-Z_][a-zA-Z_0-9]*(?!->))/';
$str = '$foo->bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);