re = /^'|';?$|;$/m
str = '\'asdfsdf\'afadf\'afafa\';
\'sfsd\'sdfsf;s\';
\'svvsvsvsv\';
\'svvsvsvsv\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end