$re = '/^(?!transport\.php$).*\.php$/m';
$str = 'transport.php
test_transport.php
transport_test.php
test_transport_test.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);