$re = '/(.+)<span.*?>(.*)<\/span>(.+)/m';
$str = '<sup><span lang="EN-US">4</span></sup>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);