$re = '/(?<= Replace)(?P<name>.*)/m';
$str = 'Hello ReplaceMe';
$subst = "Test";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;