using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w-]+\.[\w-]+\.[\w-]+$";
string input = @"e.sDsdfsdf-__sdf.d";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}