using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\S\s]+?(<a.*?(href=""(.*)"")>(.*)?<\/a>).*";
string input = @"<table id=""report"" cellspacing=""0"" style=""border-collapse: collapse;"">
<tbody><tr class=""nrhtr"">
<td style=""text-align:right; width:41px ""><b>##</b></td><td style=""text-align:left""><b>URL</b></td><td style=""text-align:right""><b>УВ</b></td><td style=""text-align:left""><b>анкор</b></td>
</tr>
<tr class=""tms""><td colspan=""4""> </td></tr><tr class=""tms"">
<td class=""nc"">181.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://offline.by/kak-ne-razvestis-v-remonte/"">Как не развестись в ремонте | Белорусский блог offline.by</a><br><span class=""url"">offline.by/kak-ne-razvestis-v-remonte/</span> 27Kb</td><td class=""nv"">4</td><td class=""na le"">http://siteproremont.ru/styazhka/nalivnoj-pol-svoimi-rukami-po-mayakam.html</td>
</tr>
<tr class=""tms"">
<td class=""nc"">182.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://nolix.ru/top/22/1/"">Каталог подключенных к системе Nolix площадок. Категория ""Строительство""</a><br><span class=""url"">nolix.ru/top/22/1/</span> 44Kb</td><td class=""nv"">4</td><td class=""na le"">школа ремонта своими руками</td>
</tr>
<tr class=""tms"">
<td class=""nc"">183.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://app21.ru/d/%D0%BF%D1%80%D0%BE%D0%B3%D1%80%D0%B0%D0%BC%D0%BC%D0%B0+%D1%87%D0%B5%D1%80%D1%82%D0%B5%D0%B6%D0%B5%D0%B9+%D1%81%D1%83%D0%B4%D0%BE%D0%B2.html"">программа чертежей судов - App21 программы полностью бесплатные скачать без sms</a><br><span class=""url"">app21.ru/d/%D0%BF%D1%80%D0%BE%D0%B3%D1%80%D0%B0...</span> 15Kb</td><td class=""nv"">4</td><td class=""na le"">Программа для создания чертежей - sPlan | Чертежи потолков</td>
</tr>
<tr class=""tms"">
<td class=""nc"">184.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://archfacade.ru/2013/06/v-italii-otkrylsya-kreativnyj-ofis-kompanii-autodesk.html"">В Италии открылся креативный офис компании «Autodesk». | Современная архитектура и фасады</a><br><span class=""url"">archfacade.ru/2013/06/v-italii-otkrylsya-kreati...</span> 35Kb</td><td class=""nv"">4</td><td class=""na le"">заделка штроб</td>
</tr>
<tr class=""tms"">
<td class=""nc"">185.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://imstat.ru/4378-mehanizaciya-transportirovaniya-stroitelnyh-materialov-na-mnogoetazhnyh-obektah.html"">Механизация транспортирования строительных материалов на многоэтажных объектах &raquo; www.imstat.ru</a><br><span class=""url"">imstat.ru/4378-mehanizaciya-transportirovaniya-...</span> 33Kb</td><td class=""nv"">4</td><td class=""na le"">потолок из гипсокартона своими руками</td>
</tr>
<tr class=""tms"">
<td class=""nc"">186.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://matrixmarket.ru/novosti-stroitelstva/otkrytye-i-zakrytye-jachejki.html"">Открытые и закрытые ячейки</a><br><span class=""url"">matrixmarket.ru/novosti-stroitelstva/otkrytye-i...</span> 35Kb</td><td class=""nv"">4</td><td class=""na le"">как сделать прямой угол между стенами</td>
</tr>
<tr class=""tms"">
<td class=""nc"">187.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://forum.deport.ru/lofiversion/index.php/t166.html"">Форум обо всем на свете > Натяжной потолок</a><br><span class=""url"">forum.deport.ru/lofiversion/index.php/t166.html</span> 19Kb</td><td class=""nv"">4</td><td class=""na le"">[img]</td>
</tr>
<tr class=""tms"">
<td class=""nc"">188.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://forum.deport.ru/lofiversion/index.php/t166.html"">Форум обо всем на свете > Натяжной потолок</a><br><span class=""url"">forum.deport.ru/lofiversion/index.php/t166.html</span> 19Kb</td><td class=""nv"">4</td><td class=""na le"">http://siteproremont.ru/</td>
</tr>
<tr class=""tms"">
<td class=""nc"">189.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://forum.deport.ru/lofiversion/index.php/t166.html"">Форум обо всем на свете > Натяжной потолок</a><br><span class=""url"">forum.deport.ru/lofiversion/index.php/t166.html</span> 19Kb</td><td class=""nv"">4</td><td class=""na le"">одноуровневом потолке из гипсокартона</td>
</tr>
<tr class=""tms"">
<td class=""nc"">190.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://promup.ru/stroymaterialy/3318-kak-provoditsya-ukladki-plitki.html"">Рекомендации по укладке плитки.</a><br><span class=""url"">promup.ru/stroymaterialy/3318-kak-provoditsya-u...</span> 17Kb</td><td class=""nv"">4</td><td class=""na le"">ремонт квартиры своими руками</td>
</tr>
<tr class=""tms"">
<td class=""nc"">191.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://nicstroy.ru/?option=com_content&task=view&id=5507"">Декоративная штукатурка у себя дома</a><br><span class=""url"">nicstroy.ru/?option=com_content&task=view&a...</span> 33Kb</td><td class=""nv"">4</td><td class=""na le"">Декоративная штукатурка</td>
</tr>
<tr class=""tms"">
<td class=""nc"">192.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://stroisoyuz.ru/remont/489-dizaynerskie-potolki.html"">Дизайнерские потолки &raquo; Информационный портал о строительстве и ремонте</a><br><span class=""url"">stroisoyuz.ru/remont/489-dizaynerskie-potolki.html</span> 20Kb</td><td class=""nv"">4</td><td class=""na le"">потолок из гипсокартона своими руками</td>
</tr>
<tr class=""tms"">
<td class=""nc"">193.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://ul-goszak.ru/novosti-remonta/zheltyj-marker.html"">Уютный дом - все для ремонта - Желтый маркер</a><br><span class=""url"">ul-goszak.ru/novosti-remonta/zheltyj-marker.html</span> 29Kb</td><td class=""nv"">4</td><td class=""na le"">декоративной штукатурке</td>
</tr>
<tr class=""tms"">
<td class=""nc"">194.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://stroy-s-umom.ru/remont-pod-klyuch-chto-e-to/"">Что такое ремонт ""под ключ"", и в чем его выгода?</a><br><span class=""url"">stroy-s-umom.ru/remont-pod-klyuch-chto-e-to/</span> 100Kb</td><td class=""nv"">4</td><td class=""na le"">штукатурка стен</td>
</tr>
<tr class=""tms"">
<td class=""nc"">195.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://rubikon.name/2013/11/05/""> 2013 Ноябрь 05 | Rubikon.name</a><br><span class=""url"">rubikon.name/2013/11/05/</span> 58Kb</td><td class=""nv"">4</td><td class=""na le"">с чего начать ремонт квартиры</td>
</tr>
<tr class=""tms"">
<td class=""nc"">196.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://asmasters.org/articles/kak-ustanovit-vhodnuyu-derevyannuyu-dver.html""> Как установить входную деревянную дверь - Ремонт: онлайн-журнал</a><br><span class=""url"">asmasters.org/articles/kak-ustanovit-vhodnuyu-d...</span> 28Kb</td><td class=""nv"">4</td><td class=""na le"">ремонт квартиры своими руками</td>
</tr>
<tr class=""tms"">
<td class=""nc"">197.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://rubikon.name/2013/11/05/s-chego-nachat-remont-kvartiryi/"">С чего начать ремонт квартиры? | Rubikon.name</a><br><span class=""url"">rubikon.name/2013/11/05/s-chego-nachat-remont-k...</span> 59Kb</td><td class=""nv"">4</td><td class=""na le"">с чего начать ремонт квартиры</td>
</tr>
<tr class=""tms"">
<td class=""nc"">198.</td><td class=""le""><a title=""перейти на сайт"" target=""_blank"" href=""http://samodellkin.net/oborudovanie/kaminy-i-pechi-dlya-derevyannogo-doma.html"">Камины и печи для деревянного дома | Блог о строительстве и ремонте</a><br><span class=""url"">samodellkin.net/oborudovanie/kaminy-i-pechi-dly...</span> 27Kb</td><td class=""nv"">4</td><td class=""na le"">потолки из гипсокартона</td>
</tr>
<tr class=""tms""><td colspan=""4""></td></tr></tbody></table>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}