import Foundation
let pattern = #"^(([^"']*?)foo(.*)|(.*?)foo([^"']*))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
hello foo
hello "foo" and foo not 'foo'
Hello "foo" foo, how are "you" doing?
they "are foo and bar" and foo
This foo " is too a match
"foo" not bar but foo
This foo ' should be matched
Then foo said "foo bar", which didn't work
"This is the foo bar"
hello "foo"
hello "foo"
hello 'foo'
you said "my name is foo"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)