re = /(?<!:)(:)(?>[a-zA-Z_]\w*(?>[?!]|=(?![>=]))?|===?|>[>=]?|<[<=]?|<=>|[%&`\/\|]|\*\*?|=?~|[-+]@?|\[\]=?|@@?[a-zA-Z_]\w*)/
str = 'def test
def self.test()
:asdf
def self.wat'
# Print the match result
str.match(re) do |match|
puts match.to_s
end