re = /({[\s\S]+})/
str = 'Topic:Cat [0] at offset:216812{"ID":51255125, "NAME":6}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end