import Foundation
let pattern = #"(?=.*FULL SET USER1)(?=.*Grp= 1)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Evnt= Closing report. System armed normally.
Dev= 0.
Grp= 1.
Usr= 2.
Xtra= FULL SET USER1.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}