$re = '/^[0-9]+([,.][0-9]+)?$/';
$str = '2.0';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);