import Foundation
let pattern = #"(?<=[_\n]|^)affiliatewire_([^_\n]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
param0_test1_param1_affiliatewire_%nameID%_test2_param2_param3
param0_test1_param1_affiliatewire_name1_test2_param2_param3
param0_test1_param1_affiliatewire_name_test2_param2_param3
param0_test1_param1_affiliatewire_trollolo_test2_param2_param3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)