$re = '/(\d{4}(?=[^\d]))/';
$str = 'test 125456 b
test125456b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);