import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# match a body pattern alone on a line\n"
+ "^\\g<body>$\n\n"
+ "# we'll use (?<name>...){0} to define the pattern \\g<name>\n"
+ "# without having to match the pattern at the current position\n\n"
+ "# a body pattern matches\n"
+ "(?<body>\n"
+ " # a sequence of\n"
+ " (?: [^\\[\\]\\{\\}()\\n] # non-delimiters\n"
+ " | \\g<parens> # parenthesized pattern\n"
+ " | \\g<square_brackets> # bracketed pattern\n"
+ " | \\g<curly_braces> # braced pattern\n"
+ " )*\n"
+ "){0}\n\n"
+ "# a parenthesized pattern matches\n"
+ "(?<parens>\n"
+ " \\( # an open paren\n"
+ " \\g<body> # a valid body\n"
+ " \\) # a close paren\n"
+ "){0}\n\n"
+ "# a bracketed pattern matches\n"
+ "(?<square_brackets>\n"
+ " \\[ # an open square bracket\n"
+ " \\g<body> # a valid body\n"
+ " \\] # a close square bracket\n"
+ "){0}\n\n"
+ "# a braced pattern matches\n"
+ "(?<curly_braces>\n"
+ " \\{ # an open curly brace\n"
+ " \\g<body> # a valid body\n"
+ " \\} # a close curly brace\n"
+ "){0}";
final String string = "matches:\n"
+ "a plain string\n"
+ "a string containing (matched parens) [matched brackets] and {matched braces}\n"
+ "nested (parens (within) parens)\n"
+ "nested [parens (within) brackets]\n"
+ "()()[({({[]})[({})]})]\n\n"
+ "non-matches:\n"
+ "(unbalanced parens\n"
+ "([balanced but misordered)]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}