import re
regex = re.compile(r"(.*?</p>){3}\K", flags=re.DOTALL)
test_str = ("<p>If you wanna improve yer German, don't try to read Heine or some elevated crap... watch old episodes of [callout]Tatort or Bukow & Konig[/callout].</p>\n"
"<p>If I were teaching a music appreciation I wouldn't teach Beethoven. I'd teach Stamitz and average composers.</p>\n"
"<p>And here is a 3rd paragraph.</p>\n"
"<p>And here is a 4th paragraph.</p>\n")
subst = "<blockquote class=\"pullquote\">Tatort or Bukow & Konig</blockquote>"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)