package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Armadale|Fremantle|Butler|Mandurah|Midland|Thornlie)[^\d\n]+2[0-9]{4}[^\d\n]+$|\b[0-9]{2,3}(?:-[0-9]{2,3}){2}\b`)
var str = `Armadale Joe Bloggs 22-333-222 20001 Whitfords to Butler
Armadale Joe Bloggs 20001 Whitfords to Butler
22-333-333
333-333-22
22-22-22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}