re = /^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[,;:])(?=.{8,16})(?!.*[\s])/
str = 'Fred:099'
# Print the match result
str.match(re) do |match|
puts match.to_s
end