// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Score[^\.]*").unwrap();
let string = "Pale straw in colour, it has that characteristic lychee and rose petal nose and Turkish delight flavour, finishing elegantly dry on a pear-like note. Score - 4 Stars. (Tony Aspler, tonyaspler.com, Feb. 2016)
The quick red fox jumped over the lazy brown dog
Score.+?\\.
.*?quick[^z]*";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}