const regex = /site\.com\/fr/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('site\\.com\\\/fr', 'i')
const str = `site.com/fr/bla
site.com/en/bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}