re = /^###(.+)### ###(.+)### ###(.+)###$/
str = '###Cannon### ###Toner### ###42A###'
subst = '$1 $2 $3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result