using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<img\b|(?!^)\G)[^>]*?\b(src|width|height)=""([^""]*)""";
string input = @"<img src=""myurl.jpg"" width=""12"" height=""32"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}