$re = '/^([123])((?!\1)\d){2}$/';
$str = '311';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);