import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\b(\\d+)\\b.*\\b\\1\\b)\\d+(?:([.\\s,])\\d+)(?:\\2\\d+)*$";
final String string = "1,2,13\n"
+ "1,14,22,3\n"
+ "1,12,12,3\n"
+ "1 2 3 44\n"
+ "1.22.2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}