package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`s;^[^?R*]`)
var str = `z R o 2 R`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}