import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z]+):\\s+([A-Z]+)\\s*(.*)$";
final String string = "CLRFCB:\n"
+ "FCB: EQU 5CH\n"
+ "SYSTEM: EQU 5\n"
+ "OPEN: EQU 15\n"
+ "CLOSE: EQU 16\n"
+ "SETDMA: EQU 26\n"
+ "CREATE: EQU 22\n"
+ "DELETE: EQU 19\n"
+ "READ: EQU 20\n"
+ "WRITE: EQU 21\n"
+ "PRNBUF: EQU 9\n"
+ " MOV SP,STACK\n"
+ " MOV DX,HEADER\n"
+ " MOV CL,9 \n"
+ " CALL SYSTEM\n"
+ " MOV BX,FCB+12\n"
+ " XOR AL,AL\n"
+ " MOV CH,4 \n"
+ "CLRFCB:\n"
+ " MOV [BX],AL";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}