re = /^(?=.*a)(?=.*b)(?=.*c)(?=.*d)(?=.*e)(?=.*f)(?=.*g)(?=.*h)(?=.*i)(?=.*j)(?=.*k)(?=.*l)(?=.*m)(?=.*n)(?=.*o)(?=.*panda)(?=.*potato)/m
str = 'A panda, a potato, and a quick brown fox jump over the lazy dog.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end